xiaolingzi's blog

每天都在成长...

欢迎您:亲

CentOS通过yum安装php7.0

称进行相应的删除二、安装新版版1.更新yum安装包CentOS7.xrpm-Uvhhttps://mirror.webtatic.com/yum/el7/epel-release.rpmrpm-Uvhhttps://mirror.webtatic.com/yum/el7/webtatic-relea
分类: PHP  标签: 基础知识 , CentOS , Linux , php , yum  日期: 2016-02-25 15:54:43

CentOS通过yum安装mysql5.7

??默认安装库安装的mysql的版本比较低,所以想安装高本版的数据库就得自己更新库在安装。具体如下:1.下载及安装mysql的yum库wgethttp://dev.mysql.com/get/mysql57-community-release-el7-7.noarch.rpmyumlocalins
分类: mysql  标签: 基础知识 , CentOS , Linux , mysql , yum  日期: 2016-02-25 16:17:45

RabbitMQ在Centos上的安装和简单配置

ocat,如果yum源没有socat会报需要socat的错误。解决办法就是下载添加socat源就好。wget --no-cache http://www.convirture.com/repos/definitions/rhel/6.x/convirt.repo -O /etc/yum.repos.
分类: Linux  标签: RabbitMQ , 消息队列 , Erlang , Centos  日期: 2017-07-11 10:33:57

Centos7 Docker容器中开启systemd(systemctl)

的例子,Dockerfile注意不要漏掉CMD那行。FROM local/c7-systemd RUN yum -y install httpd; yum clean all; systemctl enable httpd.service EXPOSE 80
分类: docker  标签: centos , docker , systemd , systemctl , linux , 容器  日期: 2018-03-27 13:57:31

linux下使用let's encrypt免费ssl通配符域名证书支持https

装docker可以直接使用yuminstalldocker进行安装,但默认安装的版本都比较低,可以先安装最新的源,再进行安装,如下:yum install -y yum-utils device-mapper-persistent-data lvm2yum-config-manager --add-
分类: Linux  标签: ssl , https , linux , letsencrypt  日期: 2018-03-28 10:19:05

centos7安装使用Let's Encrypt免费SSL证书以支持网站https方式访问

件生成Let'sEncrypt证书目前已经有linux客户端软件来生成,叫certbot。centos的yum源里面已经添加了该软件,所以为了避免安装依赖的麻烦,推荐直接通过yum进行安装,命令如下:yuminstallcertbot2.生成证书目前支持生成单域名证书和多域名,尚未支持通配符
分类: Linux  标签: SSL , HTTPS , Centos  日期: 2016-12-05 14:21:17

PHP使用thrift实现RPC服务(服务端和客户端)

_socket_closeonexec'(2)解决办法出现该错误的原因是,我原来通过yum已经安装过了libevent,版本比较旧,然后又通过源码编译安装了更新的版本,从而导致的部分冲突。通过yum卸载原来旧版本可以解决该问题。还有记得见c++,g++,gcc链接到/usr/bin下。安装
分类: PHP  标签: thrift , rpc , php  日期: 2017-06-21 15:04:53

Linux中mysql主从镜像实时同步备份

123456为密码(4)192.168.0.22为从服务器ip。各参数具体使用时请根据自身情况进行修改。2.配置my.conf文件CentOS通过yum安装的话,my.conf文件在/etc目录下。修改内容如下:在[mysqld]节点下添加以下内容#id,服务器的唯一标识,不能重复server-i
分类: mysql  标签: Linux , mysql , 备份 , 镜像 , 数据库  日期: 2016-03-07 16:20:33